Upload Errors
Incident Report for SYNQ.fm
Resolved
This incident has been resolved.
Posted 11 days ago. Dec 07, 2017 - 08:13 UTC
Investigating
Our uploading service is experiencing elevated errors at the moment.
Posted 11 days ago. Dec 07, 2017 - 08:05 UTC