Upload Errors
Incident Report for SYNQ.fm
Resolved
This incident has been resolved.
Posted 14 days ago. Jan 07, 2018 - 16:22 UTC
Investigating
Our uploading service is experiencing elevated errors at the moment.
Posted 14 days ago. Jan 07, 2018 - 16:20 UTC