Upload Errors
Incident Report for SYNQ.fm
Resolved
This incident has been resolved.
Posted about 1 month ago. Jan 13, 2018 - 17:14 UTC
Investigating
Our uploading service is experiencing elevated errors at the moment.
Posted about 1 month ago. Jan 13, 2018 - 16:47 UTC