Upload Errors
Incident Report for SYNQ.fm
Resolved
This incident has been resolved.
Posted 24 days ago. Nov 24, 2017 - 17:27 UTC
Investigating
Our uploading service is experiencing elevated errors at the moment.
Posted 24 days ago. Nov 24, 2017 - 17:22 UTC