Upload Errors
Incident Report for SYNQ.fm
Resolved
This incident has been resolved.
Posted 23 days ago. Oct 25, 2017 - 13:40 UTC
Investigating
Our uploading service is experiencing elevated errors at the moment.
Posted 23 days ago. Oct 25, 2017 - 13:19 UTC