Upload Errors
Incident Report for SYNQ.fm
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 18, 2017 - 22:28 UTC
Investigating
Our uploading service is experiencing elevated errors at the moment.
Posted about 1 month ago. Dec 18, 2017 - 22:14 UTC