Upload Errors
Incident Report for SYNQ.fm
Resolved
This incident has been resolved.
Posted 3 months ago. Oct 22, 2017 - 09:22 UTC
Investigating
Our uploading service is experiencing elevated errors at the moment.
Posted 3 months ago. Oct 22, 2017 - 09:14 UTC