Upload Errors
Incident Report for SYNQ.fm
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 15, 2017 - 15:00 UTC
Investigating
Our uploading service is experiencing elevated errors at the moment.
Posted about 1 month ago. Nov 15, 2017 - 14:46 UTC