Upload Errors
Incident Report for SYNQ.fm
Resolved
This incident has been resolved.
Posted 10 days ago. Feb 08, 2018 - 06:11 UTC
Investigating
Our uploading service is experiencing elevated errors at the moment.
Posted 10 days ago. Feb 08, 2018 - 05:55 UTC