Upload Errors
Incident Report for SYNQ.fm
Resolved
This incident has been resolved.
Posted 30 days ago. Nov 18, 2017 - 08:59 UTC
Investigating
Our uploading service is experiencing elevated errors at the moment.
Posted 30 days ago. Nov 18, 2017 - 08:49 UTC